OPSWAT Enhances Metadefender Cloud Client with Release of Detection for WannaCry Vulnerability

By using tools such as Metadefender Cloud Client, these vulnerabilities can be identified and patched in advance of attacks by malware seeking to exploit known vulnerabilities.

OPSWAT today announced the release of Metadefender Cloud Client 4.0.6. The new release includes support for detection of Microsoft Windows vulnerability MS17-010, the vulnerability exploited by the recent WannaCry ransomware. Adding support for this vulnerability will help organizations confirm their endpoints are not vulnerable to the ransomware, in addition to the powerful endpoint protection that Metadefender Cloud Client already provides for application-level vulnerabilities.

The WannaCry ransomware has spread extremely quickly around the globe, infecting over 300,000 computers in over 150 countries in less than a week since its first reported appearance on Friday, May 12. Although a patch for MS17-010 was made available by Microsoft on March 14, systems impacted by WannaCry have not had the patch applied. This latest product release from OPSWAT provides a quick and easy check to see if an endpoint is at risk.

Benny Czarny, Founder and CEO of OPSWAT, said, “With a threat like WannaCry that has spread so quickly and has such global reach, it is important for security professionals to make sure their systems are not exposed to the threat. Time is of the essence in making that determination and remediating any systems that could become compromised.

“We are proud that OPSWAT is able to provide this free tool to help administrators check for vulnerabilities in the systems they are managing. This is true not only for the immediate threat posed by the WannaCry ransomware, but also for other known application vulnerabilities that could be the target of the next ransomware outbreak….

Read the full article from the Source…

Leave a Reply

Your email address will not be published. Required fields are marked *